A JBoss Project
Red Hat

Kosmos FAQ

  1. I've just deployed the portlets out of the box, and get the following exception: com.caucho.hessian.client.HessianRuntimeException: java.net.ConnectException: Connection refused: connect

    This happens when Kosmos portlets cannot connect to services provided by the Kosmos server.
    An easy and quick check to test whether the service is available at the given URL is opening the URL in a normal browser window. You should see a Hessian requires POST error message if everything is fine.
    If not, the reason can be:

    • the URL from the portlet to the server is not correct (see the the service.url init parameter in portlet.xml). This is mostly caused if your port number is not 8080 as the default in portlet.xml. Simply change the port number and that's it!
    • the Kosmos server webapp is not running. Kosmos server is a separate webapplication, so you have to have two webapps in the deployment dir (kosmos-server and kosmos-portlet), both of them up and running.

  2. I get an error The portlet cannot be started due to an error that occcured during init, while all my other portlets are up and running.

    The binary distribution of Kosmos is compiled with JDK 1.5, you need to upgrade to at least JRE 1.5 in your environment.

  3. Does Kosmos support secure Subversion repositories?

    Yes. You just have to encode your credentials to the URL specified in monitored.urls: http://myusername:mypassword@www.mycompany.com/svn/mysecurerepo

  4. Does Kosmos support secure JIRA project databases?

    Kosmos is shipped with two different implementations for JIRA access:

    1. The service implementation based on JIRA SOAP API supports JIRA authentication.
    2. The service implementation based on web crawling does not support JIRA authentication.
    See your Reference Manual about how to choose between the two implementations.

  5. I get actionURL/renderURL Tag Exception: cannot write to the output writer. exception when deploying Kosmos to Jetspeed or Pluto.

    This is an Apache Portals bug, see the resolution here: http://issues.apache.org/jira/browse/PLUTO-120?page=all